Close

Why would I use FarmStream Fleet?

FarmStream Fleet provides more detailed vehicle utilization and sensor data using the FmX®, GFX-750™ or TMX-2050™ display and a wireless connection. There is no need for a DCM-300 modem when using FarmStream Fleet, but the DCM-300 can be used as a wireless connection.

Farming operations with more than a few vehicles and hired operators may struggle to keep tabs on equipment and operator productivity—the Fleet solution targets operations where managers are responsible for a staff of operators but cannot sit with each employee to monitor their performance and compliance.

What are the differences between FarmStream and traditional Fleet?

  • FarmStream Fleet provides vehicle utilization data using the FmX, GFX-750 or TMX-2050 display. Utilization settings are configured in the display instead of the Trimble Ag Software interface.
  • There is no need for a DCM-300 modem when using FarmStream Fleet, but the DCM-300 modem can be used with FarmStream Fleet as a communication device.
  • The FarmStream Fleet solution provides some different features than traditional Fleet. For a detailed comparison, refer to the Feature Comparison Matrix.

How do I purchase FarmStream Fleet?

FarmStream Fleet is included as part of the Trimble Ag Software Vehicle Connection license. Two Vehicle Connection Licenses come with a Farmer Pro license, and one Vehicle Connection License comes with a Farmer Fit License. Additional Vehicle Connection Licenses can be purchased separately.

The Vehicle Connection license is assigned to a vehicle in Fleet in the Trimble Ag Software.

Can I use both FarmStream and traditional Fleet on a vehicle at the same time?

No.

If a vehicle is associated with an FmX, GFX-750 or TMX display that has FarmStream Fleet enabled, you cannot also associate it with a DCM-300 modem.

How can I tell if a vehicle is set up to use FarmStream or traditional Fleet?

In the Fleet site select a vehicle and go to its individual vehicle page. This page will show whether FarmStream has been enabled. It will say “FarmStream on” or “FarmStream off”. “FarmStream on” means it is using the FarmStream Fleet features, and “FarmStream off” means it is using the traditional Fleet features.

Where can I buy FarmStream Fleet?

From your Trimble Reseller or Ag Marketplace. The part number and price for FarmStream Fleet (which is part of a Vehicle Connection license) is the same as for traditional Fleet.

Is traditional Fleet changing?

Yes.

With the release of FarmStream Fleet, you are no longer able to use the productivity features of traditional Fleet with both the DCM-300 modem and the FmX or TMX display.

The productivity features of traditional Fleet is now based on the DCM-300 modem and does not include information from the FmX or TMX display, for example, in Delay Reasons.

Do I need to create a separate Trimble Ag Software account / organization for my FarmStream Fleet vehicles?

No. You can use the same account and organization that you use for your traditional Fleet vehicles.

What equipment do I need to use FarmStream Fleet?

  • FmX integrated display, GFX-750 display or TMX-2050 display.
  • A Cable to connect the display to the vehicle. The GFX-750 display also requires an additional adapter cable.
    Part Number Description
    86995-01 Cable Assy, FarmStream, CAN diagnostic port to FmX integrated display / TM-200 Module
    90147-01 Cable Assy, Autopilot™ system and FarmStream, Vehicle CAN interface, John Deere R & RT series
    87754-01 Cable Assy, FarmStream, Vehicle CAN interface, Rogator 2005 Models 8841 & 984
    115447 Cable Assy, FarmStream, CAN Interface Adapter for GFX-750
  • A WAN gateway device (Wi-Fi, Cellular, etc.) for communications, such as the DCM-300, SNM941 or GX450 modem.

For more details and recommended hardware, refer to the FarmStream Fleet setup guide and the FarmStream Cable guide.

Can I associate a vehicle with both a DCM-300 modem and an FmX, GFX-750 or TMX-2050 display?

If you have not turned on FarmStream Fleet for an FmX or TMX-2050 display, you can assign a vehicle to both the DCM-300 modem and the FmX or TMX-2050 display. You can’t assign a DCM-300 modem to a vehicle with a GFX-750 display. If you turn on FarmStream for a vehicle with any type of display, DO NOT ASSOCIATE THE VEHICLE WITH A DCM-300 MODEM AS ITS TELEMATICS DEVICE – FARMSTREAM WILL NOT WORK PROPERLY.  The DCM-300 modem (or other modem used) works in the background as the communication device.

If you select a display for a vehicle, this indicates which vehicle you want your File Transfer (Office Sync) files to be associated with for that particular vehicle.

On which Trimble displays is FarmStream available?

Currently, FarmStream Fleet is available on the FmX, GFX-750 or TMX-2050 displays only.  It is not available on the CFX-750™ display.

What do I need to do on the FmX, GFX-750 or TMX-2050 display to set up FarmStream Fleet?

To run FarmStream Fleet on the FmX or TMX-2050 display using the FmX Plus app, you need the free FarmStream plugin.

To run FarmStream with PIQ on the TMX-2050 or GFX-750 display you must enable operators as a first step.

Firmware version 10.01 or higher is required for the FmX and version 4.3.1 or higher is required for the TMX using the FmX+ app. Version 5.5 or higher is required for TMX using the PIQ app. Version 1.5 or higher is required for the GFX-750 display.

For more information, refer to the FarmStream Fleet Setup Guide.

Can a vehicle that is running FarmStream Fleet also use the File Transfer (Office Sync) functionality?

Yes.

Can a vehicle running FarmStream Fleet also use the Vehicle Sync functionality?

The Vehicle Sync functionality requires a DCM-300 modem. The vehicle cannot use the Vehicle Sync functionality if no DCM-300 modem is installed.

Can I provision a GX450 or SNM941 modem in the website for FarmStream Fleet?

No. There is no need to provision the GX450 or SNM941 modem in FarmStream Fleet, the modem is just a router for the display.

What version of firmware is required to run FarmStream?

Version 10.01 is required for the FmX and Version 4.3.1 is required for the TMX using the FmX+ app. Version 5.5 or higher is required for TMX using the PIQ app. Version 1.5 or higher is required for the GFX-750 display.
.